Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 07, 2026 - 03:00 UTC
Scheduled
During this window we will be performing network maintenance to improve stability of services on the Legacy iDirect VSAT platform (G18 @ 123W). OneWeb, Starlink, and all other IPA SuperGIG services will not be affected.
Posted Jan 06, 2026 - 22:11 UTC
This scheduled maintenance affected: Legacy iDirect VSAT (G18 @ 123W).